
HOUDINI FOUNDATIONS 
SMASHING WINE GLASS 
In this lesson, you will smash a wine glass then slow down time to hold onto the big splash. This effect 
involves both an RBD simulation for the shattered glass and a fluid simulation for the wine. You will 
learn how to set up the dynamic network and output the simulations. Visual effect shots often involve a 
combination of different kinds of dynamic solvers and Houdini’s dynamic network is designed to achieve a 
unified result with these different solvers.
You will also use a retime node to slow down the simulation when it is at its most explosive then reverse 
time to return to the starting point. You will then move the simulations into Solaris/LOPS, set up lights and 
a camera, then render the shot using the Karma renderer.  

LESSON GOAL
To simulate a bullet smashing through a wine glass causing the glass  
to break and the liquid to splash.

WHAT YOU WILL LEARN
	� How to model the Wine Glass, Bullet and Liquid geometry
	� How to pre-fracture the glass geometry using Booleans
	� How to run a Rigid Body Simulation of the bullet smashing the glass
	� How to run a FLIP Fluid Simulation of the liquid splashing
	� How to retime the simulation to slow it down then go back in time
	� How to export the results as USD for use in Solaris/LOPS
	� How to set up lights and materials in Solaris/LOPS
	� How to render the final shot with Karma

LESSON 
COMPATIBILITY
Written for the features in Houdini 19.5+

The steps in this lesson can be 
completed using the following 
Houdini Products:

Houdini Core ✘

Houdini FX ✔

Houdini Indie ✔

Houdini Apprentice ✔

Houdini Education ✔
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PROJECT FILES
Go to the fluids tutorial page on  
SideFX.com, where you got this document 
and download the fluids_lesson_start direc-
tory. Rename it fluids_lesson then put it into 
the Houdini Projects directory.  

PART ONE
Model the Wine Glass
To start, you will draw a polygonal curve then revolve it to create the wine 
glass. Creasing will be used to sharpen some edges and then you will subdi-
vide to create denser geometry for fracturing. You will then extract geometry 
from the wine glass to create a shape that you will use to simulate the fluid. 

01 Select File > Set Project.  Find the fluids_lesson directory 
(see instructions above) and press Accept. This makes 

the project directory and its sub folders the focus for all the files 
associated with this shot. 

Select File > Save As... You should be looking into the new  
fluids_lesson directory. Set the file name to wineglass_01.hip and 
click Accept to save. Now you will be able to access the reference 
images in the Tex folder.

02 In the Scene view, Press v to bring up a radial menu and 
choose Viewport Layout > Four Views Move your cursor 

over the Front panel and press spacebar-b to expand it.

Hit D with the mouse in the viewport. Click on the Background tab 
and on the Front tab , use the file picker to navigate to $HIP then 
tex>wineglass_profile.jpg. Set the following:

	� Make sure Auto-Place is turned OFF
	� Image Offset to 0, 3 
	� Image Scale to 5, 5

Now if you dolly or pan the view, the background moves with it.

03 On the Polygon shelf, click on the Curve Polygon tool. 
This creates a Curve node with the Primitive Type set 

to Polygon. Press x and choose Grid to turn on grid snapping then 
click on point A and then to the second point which also sits on a 
grid point. Turn Grid snapping to OFF then keep tracing the image. 

Turn Grid snapping back ON for the final four points at the base of 
the glass to make sure they are aligned. When you finish at point B, 
press Enter to complete the curve. Turn Grid snapping to OFF. 

You can then click on the Edit Mode button in the Operation 
Controls bar to move any points that missed their mark.

04 Press Spacebar-B to go back to a four view layout then 
mouse over the perspective view and press spacebar-b 

again to expand it. Now you can see the curve in 3D.

Press s to get the Select tool and press n to select all the primitives 
on the curve. Press c and choose Model > Curves > Revolve. This 
will turn it into the wine glass model. 

Press 3 to go to edge selection then double click on the top edge 
of the glass then press Shift and double click on the second top 
edge and the two edges of the base.  Press tab > Crease then set 
Crease to 0.75. 

Grid snap 
first point

Shift-select 
these four 
edges

Grid Snap 
second point

Grid Snap  
last four points
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05 Press 4 to switch to primitive selection then press n to 
select all. Now press tab > Subdivide. Set Depth to 2. 

This will subdivide the model with the creased edges set up to be 
sharper than the other areas of the model. A higher Crease weight 
could make these edges completely sharp but for now a softer look 
works better.

In the Network editor, add a null node to the end of the chain and 
set its display flag. Rename this node to GLASS_OUT.

Go back up to the object level and rename the object to wine_glass.  

08 Press 3 to change to edge selection then double-click on 
the edge of the shape to select the open edge. Press tab 

and start typing polyfill. With Polyfill highlighted, press Enter. 

Set the following:
	� Fill mode to Quadrilateral Grid
	� Tangent Strength to 0. 

This creates a closed shape that will become the source for the FLIP 
Fluid later in the lesson.

09 Press 4 to change to primitive selection then press n 
select all of the primitives. Press c and choose Model > 

Polygons > PolyExtrude. Set Distance to 0.01 to create an overlap 
with the wineglass to help the fluid render properly. 

In the Network editor, add a null node to the end of the chain and 
set its display flag. Rename this node to FLUID_OUT. 

Go up to the object level, rename this object to wine. 

06 With the wine_glass node selected, press n to select all 
the primitives then go to the Modify shelf and click on 

the Extract tool. This will create an objectmerge of the wine glass 
geometry and place it into a new object. 

From the Front view, select the faces at the top of the wine glass 
and then press delete. This adds a Blast node into the network 
that removes the faces. 

Note: You can still see a ghosted version of the original wine 
glass because the Scene View is set to Ghost Other Objects. This 
setting is useful to add context to your work.
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07 Now go back to a Perspective view and double-click on 
the base of the wine glass and press delete. This adds a 

second blast node. Now you are left with interior faces where you 
want the liquid to be. The faces of the wine geometry will appear 
dark on the outside. This means that they are the back sides of the 
primitives.

Press n to select all the primitives. Press tab > reverse to reverse 
the normals so that they are facing out. The darker side of each 
primitive will now be on the inside of the shape.



PART TWO
Model the Bullet
To create the bullet geometry, you will start with a primitive sphere and slice it in half. Next you will polyextrude the open end 
then use polyfill to close the shape using quad topology. You will then subdivide to define the final shape. This object will be 
moving very quickly therefore lots of detail isn’t required.  

01 Go to the object level and in the Network view, turn off 
the Display Flags for the wine and wine_glass objects. In 

the Scene View, press c and choose Create > Geometry > Sphere.  
Press Enter to place it at the origin then dive inside and set the 
following:

	� Orientation to X axis
	� Radius to 0.2, 0.125, 0.125
	� Columns to 12

Press tab > clip in the Scene view then press n to select all the 
primitives and press Enter and set the Direction to 1, 0, 0. 

02 Click on the Select tool then press 3 to turn on edge 
selection and double click on the open end of the sphere. 

Press c and choose Model > Polygons > PolyExtrude.  

In the Extrusion tab, set the following:
	� Transform Extruded Front to ON
	� Translate Z to 0.04
	� Scale to 0.7, 0.7, 0.7

This adds a little extra geometry before you remove the triangles at 
the front of the bullet then close the shape.

03 Tumble around and press s to get the select tool and 4 to 
get face/primitive selection. Select one of the triangles at 

the tip of the bullet then press and hold the a key and then middle 
click two triangles over to select all the triangular faces. Press the 
Delete key to remove them. This adds a blast node to the network.

In the Network View, press tab > polyfill and place the node after 
the blast. Set Fill mode to Quadrilateral Grid and Corner Offset to 
1 then turn on its display flag. This will close both ends of the bullet 
with good quad topology. 

04 Now add a Subdivide node at the end, set Depth to 2 
and then set its display flag. 

In the Network editor, add a null node to the end of the chain and 
set its display flag. Rename this node to BULLET_OUT. 

Go back to the object level and rename this object bullet. Turn on 
the display flag for the wine_glass. Translate the bullet to about -20 
in X and 5 in Y. You may want to go back to the Front orthographic 
view to make sure it is aimed at the desired impact point on the 
wine glass.

Save your work.

1. LMB-click

2. Press A then             
MMB-click Press Delete Polyfill to Close
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02 Go to a Right view and press v > Shading > Wireframe 
to go into wireframe mode. You can see the bullet sitting 

behind the grid and the wine glass. Press n to select the whole grid 
then go to the Create shelf and click on the Draw Curve tool. 

Draw curves over the wine glass that converge where the bullet 
hits the glass. Also add some curves across the stem of the glass 
since that will shatter as well. If at any point you draw a curve you 
don’t like, press Ctrl-Z to undo it.

03 Go to the Select tool then Press n to Select all the 
curves then press c and choose Model > Polygons > 

PolyExtrude.  Set Divisions to 4.

In the Extrusion tab, set the following:
	� Transform Extruded Front to ON
	� Transform Space to Global
	� Translate X to -4.5

Next, click away then select all the geometry and press tab > 
Transform. Set Translate X to 2.25 to center this geometry around 
the origin.

04 Press s to bring up select tool, then press 4 to go to 
primitive selection. Double click on one of the sheets to 

select the whole thing. Press tab > Duplicate to create a copy. Use 
the Rotate [r] handle to reorient the duplicated sheet to be almost 
orthogonal to the others, making sure it cuts through the cup but 
avoids the stem. This will break the cup in the other direction to 
create more realistic slivers of glass.

Repeat with another sheet to create another surface for cutting at a 
different angle.

01 In the Scene View, go to the object level then press c and 
choose Create > Geometry > Grid.  Press Enter to place it 

at the origin then i to dive inside and set the following:
	� Orientation to YZ Plane
	� Center Y to 4
	� Size X to 5
	� Size Y to 8
	� Rows to 16

This will create a drawing surface for the Draw Curve tool that 
matches the shape of your wine glass.

PART THREE
Fracture the Wine Glass
To define the cracks in the wine glass, you will create natural looking lines using the draw curve tool then extrude them into 
sheets of geometry. You will then agitate the surfaces using the mountain tool. This chaotic looking shape can then be merged 
into the wine glass object where you will set up a boolean operation that uses the sheets to shatter the glass.
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06 Next dive into the wine_glass object. In the Network 
view, press tab > object merge and place the node 

down. Click on the node selector next to Object 1 and navigate to 
fracture_geo > FRACTURE_OUT and select that node. Make sure 
that Transform is set to Into Specified Object .

This brings the agitated sheets into the wine glass geometry 
network where you can use it to boolean shatter the glass.

07 In the Network view, press tab > boolean and click to 
place down the new node. Wire the subdivide node 

(not GLASS_OUT) into the first input and the object_merge into the 
second. Set its Display flag then set the following:

	� Set B: Treat As to Surface
	� Operation to Shatter (Pieces of A)

To visualize the cracks, add an exploded view node at the end of 
the chain. If you want to change how things work then you can go 
back to the fracture_geo object and edit the sheets. Those edits will 
update procedurally.

08 In the Network view, add a Null node that bypasses the 
exploded_view node and rename it GLASSFRACTURE_

OUT. Set the display flag on this node. 

You now have two output nodes for this network. GLASS_OUT 
gives you the wine glass in its original form and GLASSFRACTURE_
OUT gives you the shattered glass. You will use them both down 
the line to complete the shot.

Save your work.

05 Select all the geometry and then press tab > Mountain to 
add some noise to the points on the different sheets. Set 

Amplitude to 0.75. This will create more interesting cracks in the 
glass.

In the Network view, add a Null node to the end of the chain and 
rename it FRACTURE_OUT. Set the display flag on this node. 

Go to the object level and name this node to fracture_geo then turn 
OFF its display flag to hide it.

BOOLEAN SHATTER
The Boolean node is often used to create traditional booleans such as 
Union, Intersect and Subtract. While these work well with closed shapes, 
you can use the Shatter option to slice up the geometry with sheets.

Houdini has a Voronoi Shatter tool that can also be used but it will not give 
you the jagged look you need for broken glass. There is also an RBD Material 
Fracture node that can create glass-like fractures. These work best with flat 
surfaces which is why it wasn’t used in this lesson for the wine glass.

Boolean Shatter

Voronoi

RBD Material
Fracture
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02 Go to the Collisions tab and click on the Ground Plane 
shelf tool. This will create an infinite ground plane for 

your geometry to collide with. 

You can turn Off the Display flag on the groundplane_object to hide 
it from the scene view. It will still function as a colliding surface in 
the simulation.

03 Dive into the AutoDopNetwork node. Select the wine_
glass node and in the Physical tab set Density to 2000, 

which is approximately the density of glass. 

Press Play in the playbar to see what happens. The glass falls and 
hits the ground.  Right now gravity is the only force acting on the 
pieces.

You could set up a glue network to hold the pieces together until 
impact but the bullet will be so fast that connecting the parts is not 
necessary.

01 Go up the object level, select the wine_glass object then 
from the Rigid Bodies shelf, click on the RBD Convex 

Proxy tool. This will set up the initial dynamics network for you. It is 
called AutoDopNetwork. Press v > Shading > Smooth Wire Shaded. 

This tool is used to break down the parts of the wine glass into 
convex shapes that can be used to create complex collisions. 
These will appear rougher than the source geometry but after the 
simulation, you can go back to visualizing the cleaner topology.

PART FOUR
Set up the RBD Simulation
You are now going to create a rigid body simulation using shelf tools. This will add a DOP (Dynamic Operator) network that 
brings together geometry, forces and a solver node. In the wine glass geometry network, nodes will be added to prepare the 
geometry for simulation. You will use convex proxies so the Bullet RBD solver can handle the odd-shaped pieces of glass. 

CONVEX DECOMPOSITION
For RBD simulations, Houdini uses the Bullet solver which prefers 
convex shapes in order to maintain fast simulation speeds. Convex 
Decomposition lets you take shapes that are concave and break 
them down into convex shapes that are connected together. These 
are then simulated as one composite piece by the Bullet solver. 

Since the wine glass fragments come in a variety of shapes, convex 
decomposition ensures accurate collisions for all pieces. Original Geometry Convex Decomposition

1
2

3 4

5
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06 Before you simulate, you want to make sure that the base 
of the glass stays on the ground. Navigate into the wine_

glass object and in the display bar, turn on primitive numbers. You 
can see that in this case the base packed primitive is 171 - yours 
will probably be different.

Add an Attribute Create node between the create_packed_primitive 
and proxy_geo nodes. Set the following:

	� Group to !171 (or whatever number your base is)
	� Name to active
	� Value to 1, 0, 0, 0   

07 Next, set the display flag on the transform_hires node and 
open up Global Animation Options and set End to 50. 

Now play back the sim. You can now see the source geometry 
being animated to match the proxies but the collision is as dramatic 
as it could be.

08 The Bullet sim defaults to 10 substeps on the solver. This 
isn’t enough to resolve collisions for the speed the of the 

bullet. Go up to the object level and on the AutoDopNet node set 
Substeps to 5. This will add substeps on top of the solver setting. 
This may take longer to simulate but will increase accuracy and 
generally make the simulation more active.

Play the simulation again to see that the collisions are looking much 
better. Go back and tweak settings if you want too change things. 
You can even go back and reposition some of the cracks.

Save your work.

05 Go up to object level and select the bullet object and 
then go to the Rigid Bodies shelf and click on the RBD 

Objects tool. This will create a packed rbd object from the bullet 
and add it to the dynamics network.

Navigate into AutoDopNetwork and select the bullet node. 
	� In the Initial state tab, set Velocity to 400, 0, 0. 
	� In the Physical tab set Density to 20000 

This is the density of lead and should work well for the bullet. 

04 Go up to object level and dive into the wine_glass object. 
A number of nodes have been added to create the proxy 

geometry and this chain ends with the dopimport node which is 
currently displayed. 

On the convexdecomposition node, you can change Max Concavity 
to 0.05 to adjust your collision geometry. 

Press Play to watch it simulate.
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DISPLAY AND RENDER FLAGS
When the wine_fluid geometry network is first created, the  
Display flag is on the dopimport node which shows particles 
while the Render flag is on the null node which flows from 
a particle surface node. This set up is meant to give you fast 
performance in the viewport and if you render then you see the 
final surface. In this lesson, you will be caching out the surface 
therefore these nodes will not be used to render.

02 Select the flipsolver1 node and click on the Particle 
Motion tab, under Behavior set:
	� Add ID Attribute to ON 

Under Reseeding set:
	� Reseed Particles to OFF 

In Volume Motion, set: 
	� Velocity Transfer to (APIC) Swirly

Under Surface Tension, set:
	� Enable Surface Tension to ON
	� Surface Tension to 500

03 Press Play to run the simulation. With extra substeps it 
will take a little longer but will give you more accurate 

results. Simulate to just past frame 10 and press Escape to stop the 
sim. Go to frame 10 to preview the fluid so far. 

To see it as a surface, go up to the object level and go into the wine_
fluid object. Set the display flag on the Render null node to see the 
surfaced fluid. This will take longer to cook but will show you what 
the surface is going to look like at each frame.

01 Go to frame 1. Select the wine object in the Network 
view and from the Particle Fluids shelf, click on the FLIP 

Fluid from Object tool. 

This turns the fluid into a volume of fluid particles. In AutoDopNet, 
select the flipfluidobject node and set Particle Separation to 0.05. 
This creates more particles which in turn adds more detail to the 
simulation.

PART FIVE
Add Fluids to the Simulation
Now that the bullet is smashing the glass, it is time to convert the wine object into a fluid that will become part of the inte-
grated simulation. This means that the RBD and Fluid simulations take place in the same DOP network and will work as one 
system. At first, the fluid will be represented by particles that can then be surfaced to visualize the fluid.

99

A
dd


 F

luids


 
to

 the


 
Simu




lation







03 Add a Retime node after the compressed_cache node and 
set its Display flag. Set the following: 
	� Evaluation Mode to By Frame.
	� Turn ON the Scale Velocities option

RMB-click on the Frame field and choose Delete channels. 
	� At frame 1: set Frame to 1 and Alt-click to keyframe
	� At frame 5: set Frame to 1 and keyframe
	� At frame 10: set Frame to 7 and keyframe
	� At frame 40: set Frame to 10 and keyframe
	� At frame 45: set Frame to 1 and keyframe

04 Click on the Animation Editor pane to see the animation 
curve you just created. Press h over the graph to home 

the view and then RMB-click-drag to zoom out a bit.

Click and drag on the curve handles to get a shape similar to what 
you see here. If you need to break tangents on a curve, select the 
key and press T to untie the tangents. Then select and drag on 
each end individually. The goal here is to have the liquid splash out 
quickly then slow down until is freezes for a short time then speed 
out into a fast reconstruction back to its original shape.

02 When it finishes, stay at the geometry level. From the 
Visibility menu in the top right of the Scene view, select 

Hide Other Objects. 

Set Load from Disk to On and Scrub through the geo sequence. 
It will only play for 10 frames. You are now going to retime the 
sequence to stretch it out over 50 frames and slow down the 
effect.

01 At the object level, delete the wine_fluid_interior node 
that the shelf tool created. Dive into the wine_fluid object. 

Delete all the nodes except the import_wine, compressedcache node 
and the particlefluidsurface nodes. 

On compressed_cache, set the following:
	� Base Name to wine_fluid
	� Base Folder to $HIP/geo/fluid/
	� Turn Off the Version check  box
	� End to 10 (RMB-click > Delete Channels first)

Hit Save to Disk.

PART SIX
Cache and Retime the Simulations
For this shot, you only need to compute 10 frames of the simulation. You will save this to disk then use a retime node to create 
a longer shot where the fluid slows down then reverses in time. The retimed fluid particles will then be surfaced and output as 
a 50 frame sequence which will define the final shot for rendering. The wine glass and bullet will then be retimed to match.
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08 Go to frame 1 and navigate into the wine_glass network. 
Beneath the transform_hires node, wire in a File Cache 

node and set the following: 
	� Base Name to glass_pieces
	� Base Folder to $HIP/geo/
	� Turn Off the Version check  box
	� End to 10 (RMB-click > Delete Channels first)

Hit Save to Disk. Set Load from Disk to On and Scrub through 
frames 1 to 10 to make sure that it looks correct.

06 Add a USD Export node to the end of the chain. Rename 
it wine_surface. Set the following
	� Valid Frame Range to Render Frame Range 
	� Output File to $HIP/usd/wine_surface.usd 

Hit Save to Disk.

07 Select the retime node and press Ctrl-c to copy it. You will 
paste this in another network to retime the shattering 

wine glass. This will ensure that the keyframes match in both of the 
networks. 

Save your work.

05 Make sure that the retime node is wired into the 
particlefluidsurface node then set it’s display flag. This 

will give you your final fluid based on the retiming. Select the 
particlefluidsurface node and keep:

	�  Method set to Average Position 
	� Set Union Compressed Fluid Surface to Off.

In the Filtering tab turn:
	� Dilate to ON and set it to 2.
	� Smooth to ON and set it to Laplacian Flow

RETIME
The most interesting part of the smashing wine glass is the first 10 seconds. To 
emphasize this part of the simulation, you are going to save out the fluid particles 
for the 10 frames then uses the retime node to stretch out the sequence in a sort 
of “bullet-time” effect that snaps back to the original wine glass by reversing time. 

Once you have this set up for the fluid, you can surface the points and save out a 
longer sequence. The same retime node can then be copied and pasted to be used 
on the smashing glass and the bullet.
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11 Add a USD Export node to the end of the chain. Set the 
following
	� Valid Frame Range to Render Frame Range 
	� Output File to $HIP/usd/wineglass.usd 

Hit Save to Disk.

10 Add a switch node into the network. Feed the GLASS_
OUT into it first and attribdelete node into it second. 

Set Select Input to $F>5 && $F<45. Scrub in the timeline to 
see how this works. This expression makes the switch from the 
unbroken glass to the broken glass at frame 5 and then back at 
frame 45.

You are putting these shapes together so that the glass is unbroken 
before and after impact in the wineglass USD file.

09 Press Ctrl-v to paste in the retime node and place it after 
the filecache node and set its Display flag. Now you have 

the same timing on the glass that you have on the fluid. You can 
scrub through the timeline to watch the timing of the pieces.

After the retime node, add an Attribute Delete. From the arrow 
next to Primitive Attributes, select name to remove this attribute 
from the geometry.

12 Go to frame 1 and select the bullet object. From the 
Modify menu, select Extract. This gives us the world 

space position of the geometry. Dive into extract_object and, Paste 
the retime node beneath the object_merge node then connect them. 

Add a USD Export node to the end of the chain. Rename it bullet. 
Set the following

	� Valid Frame Range to Render Frame Range 
	� Output File to $HIP/usd/bullet.usd 

Hit Save to Disk.

USD and SOLARIS
To support the look dev stage of this project, you are caching out the fluid, the 
wine glass and the bullet to USD. By doing this, you can focus on rendering 
without worrying about simulations being recalculated. Here you will display the 
caches in the same scene file as the simulations but another option would be to 
start a new scene file and import the caches into that file. This would let you focus 
on lighting and rendering your shot but would make it harder to go back and tweak 
the sim.
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01 Change the desktop to Solaris. Choose Stage from the 
path bar. 

In the Network View press tab > Reference then click to add a 
Reference node. Next to Reference File, click on the File Chooser 
and find the wineglass.usd file. Rename the node to wineglass. Set 
the Primitive Path to /geo/$OS - this will use the node name and 
place it into a group called geo.

In the Scene View, use your view tools such as spacebar-h for 
homing the view to get a better look at the wine glass.

02 Alt-drag on this node to make a copy and again to make a 
second copy. For the first copy, click on the File Chooser 

and find the wine_surface.usd file. Rename the node to wine.  

Repeat to make another copy, find the bullet.usd file. Rename the 
node to bullet. 

Add a Merge node to the network and wire all three reference 
nodes into it. Set its display flag then scrub to see the results.

In the Scene Graph, you can see a geo entry and underneath that 
you will find the three referenced USD files.

PART SEVEN
Set up and Render the Shot
To render the shot, you will reference the USD files into the Solaris Stage then add a backdrop. Solaris is the context of Houdini 
that uses LOP nodes to set up the USD Scene Graph. Next, you will add and position a camera and then an environment light. 
The Karma renderer will then be invoked in the viewport to create a preview render of the shot.

03 In the Network view, press tab and type out Grid. Click 
to place down the node, rename it backdrop and wire it 

into the merge node. Set Import Path Prefix to /geo/$OS. Double-
click on the backdrop node to dive down to the geometry level. 

Select the Grid node and set the Size to 200, 200 and Rows and 
Columns to 20. RMB-click on the grid node’s output and type 
Bend. Click to place a bend node and set its Display Flag then set: 
Bend to 75, Capture Origin to -40, 0, 0, Capture Direction to -1, 0, 
0, and Capture Length to 20. RMB-click on the grid node’s output 
and type Subdivide. Set its Display Flag then set Depth to 2.

CACHING OUT SIMULATIONS
To support the look dev stage of this project, you cached out the fluid, the wine 
glass and the bullet to geometry (USD) sequences. By doing this, you can focus on 
rendering without worrying about simulations being recalculated. 

This is a typical workflow when working on VFX shots that can consume LOTS OF 
HARD DRIVE SPACE. You should be aware of this before sending off huge simula-
tions with lots of particles - make sure you have somewhere to store the various 
intermediate stages.
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05 From the LOP Lights and Camera shelf, Ctrl-click on the 
Environment Light tool. This adds a domelight node to 

the end of the chain.

Select the domelight node and from the Base Properties tab, click 
on the File Chooser   button next to Texture. Click on the $HFS/
houdini/pic/hdri listing in the sidebar then select the HDRIHaven_
skylit_garage_2k.rat file. Click Accept.

On the Display Options bar. Click on the High Quality Lighting 
with Shadows button.

06 From the Persp menu, choose Karma to render with 
Karma in the viewport. You can move to different frames 

in the timeline and the viewport will update quickly.

Karma is designed to work with USD which is why everything in the 
LOP context is converted to the USD scene graph. You can only use 
the Karma renderer from this part of Houdini. 

04 Use your view tools to look at the wineglass from the 
front. From the LOP Lights and Camera shelf, Ctrl-click 

on the Camera tool. This adds a camera node into the network and 
you are now looking through the camera in the viewport. 

Press the Lock Camera/Light to View button so that view changes 
can be used to reposition the camera. Now Tumble, Pan and Dolly 
in the viewport to reposition the camera so the wineglass is on the 
left and the splash moves to the right. Scrub the timeline to make 
sure the camera works for the whole sequence.

07 To get a cleaner image when you render, you can turn 
on Denoiser if you have an Nvidia graphics card and you 

have installed the latest drivers. You can turn it on in the Display 
Options bar.

VIEWPORT RENDERING
You are now going to render the sequence using Houdini’s renderer 
Karma. At first this will render using settings you can find in the Display 
options. Press d in the Scene View to bring it up. You can turn on the 
denoiser here, set Pixel Samples and the Image Resolution.  

Later when you set up a Karma LOP, there will be render settings on 
that node which will be used to create the final output.

Turn ON 
Denoiser
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01 In the Network view, press tab > Material Library. Wire it 
into the end of the chain then set its Display Flag.

Go to the Material Palette pane. Click on the arrow next to /stage/
materiallibrary to open up this area. Scroll through the material 
gallery on the left of the palette and drag two Glass materials into 
the materiallibrary working area for the wineglass and wine.

Now find a copper material and drag it into the materiallibrary 
working area. You will use this for the bullet.

02 Select the second glass material and rename it to wine. 

Set Inside IOR to 1.3443 which is an IOR for wine. Next, 
set Reflectivity to 0.2 to reduce how much the surroundings are 
reflected. 

Set Transmission Color to 0.2, 0, 0 which will create a reddish wine 
look. Next set At Distance to 0.3.

03 Go back to the Stage level. After the Material Library 
node, add an Assign Materials node.

From the Scene Graph, drag the wineglass to the Primitives field 
then click on the arrow next to Material Path and choose the glass 
material for this primitive. 

Now click the Plus Sign next to the check box twice to add two 
new entries. Use the same method to assign the wine material to 
the wine primitive and the copper material to the bullet primitive.

PART EIGHT
Assign Materials and Render a Sequence
Now you can add materials to the wineglass, wine and bullet. These materials will become part of the USD Scene Graph and 
will get assigned to the geometry using a LOP node. You can then use a Karma LOP to prepare your render settings including 
the use of the Nvidia Optix Denoiser. After you render, you can load the sequence into Mplay to review the results.

SCENE GRAPH
Just like the geometry and lights, the materials you add using LOP 
nodes are added to the Scene Graph. When you used the Material  
Library LOP, the default setting for the Material Path Prefix was  
/materials/ and that is where they are placed in the graph. You 
could choose to organize them differently but this is the default.

This material path is the one you used in the Assign Materials LOP 
to place the materials onto the geometry.
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04 In the Network View, press tab > Karma to add a Karma 
Render Settings and USD Render ROP node. Wire them 

into the end of the chain. Select the karmarendersettings node and 
on the Image Output > Filters tab set Denoiser to nvidia Optix 
Denoiser to turn the denoiser back on.

Select the usdrender_rop node. Set Valid Frame Range to Render 
Frame Range and set the Output Picture to $HIP/render/
wineglass_$F4.exr. The $F in the name is needed to add frame 
numbers to the renderings and the 4 is the padding of the frame 
number. 

05 The denoiser from the viewport will not affect the output 
from this node therefore you much choose it explicitly. 

Select the karmarendersettings node and on the Image Output 
> Filters tab set Denoiser to nvidia Optix Denoiser to turn the 
denoiser back on.

The nVidia Optix Denoiser will match the one used in the viewport. 
There is also an Intel OIDN denoiser which is only available when 
rendering to disk.

Save your work. Select the usdrender_rop node and click on Render 
to Disk. 

06 When you finish, choose Render > Mplay > Load Disk 
Files and open up the rendered images to review the 

final sequence. 

Later you can branch off another Karma node to up the resolution 
and render settings for your final rendering. You can go back to 
Convergence Mode set to Variance, up the sample count and turn 
off the denoiser. It is always good to complete test renderings at a 
lower resolution first to make sure that everything is working the 
way you expect it to.
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CONCLUSION
You have now created a complete VFX shot using the Bullet RBD and FLIP 
Fluid solvers to smash a wine glass. You used the retime node to slow 
down then reverse time so that the wine glass finished in the same posi-
tion as it started then you cached out the results to USD files. 

These were then used to set up and light your shot using the Solaris/LOPS 
context. Materials were created and assigned to the primitives get the 
right look for your shot. 

This project shows how you can use Houdini’s dynamic nodes and net-
works to integrate different kinds of effects while using geometry nodes to 
set up and output the simulations. 

Now that you have an understanding of the nodes and networks used to 
create VFX shots. This will assist you as you dig deeper into Houdini to 
achieve your own effects. 

Enjoy!


