
HOUDINI FOUNDATIONS 
WELCOME TO HOUDINI 
In this lesson, you will take your first steps into Houdini as you model a coffee cup then use dynamics to 
simulate a collection of gumballs falling into it. You will apply textures and materials, add lights and a camera 
then render out the finished sequence. By touching all aspects of this shot, you will begin learning how to 
navigate your way through Houdini and its node-based workflow. 
One of the main goals of this lesson is to explore the Houdini user interface and discover some of its most 
important tools. You will learn how to work interactively in the Scene View and how to use the Network 
View to manage your nodes as you refine your model and set up the Rigid Body Simulation. You will also 
set up materials and textures on the Solaris Stage then render using Houdini’s built-in renderer Karma XPU. 
Along the way you will use Houdini’s new image engine called Copernicus to create a Texture map and to 
add a Slap Comp to the final shot. 

LESSON GOAL
Model, Render and Simulate gumballs falling into a cup using Houdini’s procedural node-based workflow

WHAT YOU WILL LEARN
	� How to work with the View Tools
	� How to use Shelves, Radial Menus and the Tab key to access tools
	� How to create a model using polygonal Geometry
	� How to work with Nodes and Networks
	� How to use Rigid Body Dynamics
	� How to set up and assign Materials 
	� How to create Texture Maps using Copernicus
	� How to Layout a shot and render with Karma XPU
	� How Nodes help you make last minute changes
	� How to set up a Slap Comp

LESSON 
COMPATIBILITY
Written for the features in Houdini 20.5+

The steps in this lesson can be 
completed using the following 
Houdini Products:

Houdini Core ✔

Houdini FX ✔

Houdini Indie ✔

Houdini Apprentice ✔

Houdini Education ✔
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PART ONE 
Model a Cup
To get started, it is important to learn how to explore the Houdini workspace with a focus on the panes you will 
use on a regular basis. The Scene View panel lets you create objects interactively, while the Parameter pane lets 
you edit node properties and the Network Editor lets you work directly with nodes. Learning how to work back 
and forth between these interface elements will be an important skill moving forward.  

02 In the Scene view, press c. to bring up a radial menu. 
Choose Create > Geometry > Tube. Your cursor now 

shows the outline of a box waiting to be placed in the scene. Press 
Enter to place it at the origin.

From the Operation Controls bar at the top of the Scene View, set 
the following to shape the cup:

	� Radius to 0.7, 0.5
	� Height to 1.5 
	� Rows to 6 
	� Columns to 14

03 You can now explore the cup using the View tools. Press 
the following hotkeys:

	� Tumble 	 Spacebar or Alt[Opt] - LMB click-drag
	� Pan	 Spacebar or Alt[Opt] - MMB click-drag
	� Dolly	 Spacebar or Alt[Opt] - RMB click-drag

In some cases, you will want to home in to get your bearings. 
There are some hotkeys for that as well:
	� Home All 	 Spacebar - A
	� Home Selected	 Spacebar - G
	� Home Grid [If Construction Plane is on]	 Spacebar -H

RADIAL MENUS
One way to access tools in Houdini is radial menus which you can  
access using the X, C and V hotkeys. Each of these brings up a radial 
menu with lots of options for you to choose from. The main focus  
of each menu is as follows:

	� Snapping 	 X
	� Main (or Custom)	 C
	� View	 V

01 Select File > New Project.  Change the Project Name to 
overview_lesson and press Accept. This creates a project 

directory with subfolders for all the files associated with this shot.

Select File > Save As... You are inside the overview_lesson directory. 
Set the file name to gumballs_01.hip and click Accept to save. 

You now have an empty workspace with different panes. The main 
panes are the Scene View, the Network View and the Parameter 
Pane. At the top are Tool Shelves and at the bottom is the Playbar.

In the Scene View, Press D to open the Display Options. Click on the 
Background tab and set Color Scheme to Dark Grey.
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04 In the perspective view press Spacebar - b to change to 
a four view layout. Now you can see Top, Front and Right 

views along with the Persp view. 

In the viewport, press v to bring up another radial menu. From this 
menu, choose Shading >Smooth Wire Shaded. Now you can see 
the topology of the surface which will assist when modeling the 
cup.

You can use your view tools in all four of these views. If you click on 
the Viewport Layout menu at the top right then you can set Link 
Ortho Views to ON. Now view changes are synced in these views.

06 In the Scene view, press Tab and start typing out Match 
Size. Select it from the list and press Enter. 

In the Parameter pane, set Justify Y to Min to Same. This lifts the 
cup up to sit on the ground. 

The Tab menu is another way of accessing tools. As you become 
more familiar with tool names the tab menu will be easier to use.

Generally tools act on the selection you have in before you choose 
the tool. You can also use a tool without a selection in which case 
you follow the prompts at the bottom of the Scene View to make 
the necessary selections then press Enter.

07 Press s to get the Select tool. Press 3 to get Edge 
selection then double click on the bottom edge of the 

tube. Go to the Polygon shelf and click on Polyfill. The shelf is 
another way of accessing tools.

In the Parameter pane, set the following 
	� Fill Mode to Quadrilateral grid
	� Corner offset -5
	� Tangent Strength 0

In the top view you can see the grid aligns with the Z axis.

SELECTION HOTKEYS
If you are using the Select, Move, Rotate, Scale or Handles tools, 
the following hotkeys will determine your selection mode as well as 
which level you will be working at.
	� Objects  	 Object Level	 1
	� Points 	 Geometry Level	 2
	� Edges 	 Geometry Level 	 3
	� Primitives/Faces 	 Geometry Level	 4
	� Vertices 	 Geometry Level	 5

RMB-click to access menu
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05 Press s to get the Select tool. You can also access this on 
the left side of the Scene view. 

In the Scene view, click on the tube to select this object.  Press 4 to 
get Primitive selection which moves you from the Object level to 
the Geometry level. The tube appears unselected in this context. 
Double-click on the geometry to select all the primitives.

The Object level lets you work with the positioning of objects while 
the geometry level is where you define the shape of objects. The 
word Geometry is in the top corner of the Network view. The nodes 
in this context are called Surface Operators or SOPS for short.



SHADING OPTIONS
There are a number of Shading Options available from either the  
View radial menu or the Shading menu in the top right of the Viewport. 

For the shading of your objects, the lighting is determined by the  
Display Options on the right edge of the Viewport. You can choose 
from a headlight, normal lighting or high quality lighting with shadows. 

To quickly toggle from your shaded view to wireframe press the W key.

08 Press s to get the Select tool. Press 2 to choose Point 
selection then in the Front view box select the middle 

two rows of points. Now press tab > Soft Transform. Press E to get 
a scale handle. In the top view click drag on the XY square to only 
scale in X and Y to puff out the middle of the cup. 

Now drag on the Rad control in the bottom left corner to set the 
Soft Radius on this edit. Set it to around 0.75 to round out the 
shape. You can also access the parameter in the Parameter pane.

This action added an edit node to the network view.

09 Press s to get the Select tool.  Press 4 to go back to 
Primitive selection then double-click on the geometry to 

select all the primitives. 

Press c and choose Model > Polygons > PolyExtrude. Drag on the 
handle to set the Distance on the geometry to around -0.1. 

In the Parameter pane, go to the Extrusion > Output Geometry and 
Groups section and set Output Back to ON. This puts geometry on 
the inside and outside of the extrusion.

10 Right now the cup is a blueish color which means the 
surface normals are pointing the wrong way and the 

geometry is inside out. You can fix this easily. 

Press s to get the Select tool. Double click on the geometry to 
select all the primitives. In the Scene view, press tab > Reverse. The 
normals are now corrected.

11 Press s to get the Select tool. Click in empty space to 
make sure that nothing is selected. Press c and choose 

Model > Polygons > PolyBridge.  

Tumble around to find the side facing the -Z direction, select the 
primitive that is second from the top. Press Enter. Now select the 
primitive second from the bottom. Press Enter.

In the Parameter pane, set the following:
	� Divisions to 10
	� Spine Shape to Curved
	� Default Paring Shift to 1

Disable Lighting

Headlight Only

Normal Lighting

High Quality Lighting

High Quality with Shadows

-Z
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SUBDIVISIONS
In this lesson you used a subdivide node to add geometry to your model that you may need 
for future modeling actions.  The Subdivision display makes the display smoother without 
adding any geometry which keeps you model lighter to work with. Both are valid methods to 
subdivide your model while working in the Scene view.

When you render, you will want to turn on Render Polygons as Subdivision because this will 
render smoothly at the micropolygon level no matter how close you get to the model. This 
lets you avoid tessellation on the edges that breaks up the smoothness of the object. 

13 Click on the Bridge tab and scroll down to the Thickness 
section. Set Thickness to around 0.66 then add a point to 

the middle of the Thickness Scale Ramp and push it down to thin 
out the handle in the middle.

12 In the Footings section of the Parameter pane, go to the 
Destination section and set Arrive to Along. Now you 

can drag on the handles to play with the magnitude of the top and 
bottom. To match this image, set the Source > Magnitude to 3 and 
the Destination > Magnitude to 2.

Under Source, set the Depart to Auto Using > Explicit Direction. 
This gives you a handle that you can rotate a bit to angle the handle 
up. Under Destination you can set Arrive to Along > Explicit 
Direction. Again this gives you the ability to shape the handle of the 
cup further.

14 Press s to get the Select tool. Press 4 to get Primitive 
selection, double click on the geometry then press tab > 

Subdivide. This adds more polygons to your model.

Press s to get the Select tool. Double click on the geometry then 
press tab > Color.  in the Parameter pane, change the Color to an 
Orange.

In the Network view, RMB-click on the output knob of color and 
start typing Null. Select Null and place the node. 

Hover over the node and click in the top right to set its Display flag. 
Rename the node to CUP_OUT.

15 Press v to and choose Shading > Smooth Shaded. Press 
Shift + to turn on Subdivision display. This subdivides the 

model without adding any geometry.

Go up to the Object level and rename the object to cup. 

In the Parameter pane, click on the Render tab. The Display As is 
set to Subdivision Surface/Curves. This affects viewport display 
but not rendering. Turn on Render Polygons As Subdivision so the 
model will render with subdivisions later in the lesson.

Press Shift - to turn off the Subdivision display. You can toggle it on 
at any point. Press v to and choose Shading >Smooth Wire Shaded. 
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01 Press i to go back to the Geometry level. Click on the 
little up arrow in the divider between the Node view and 

the Parameter pane. This expands the Node view up. Use the RMB 
to zoom in and the MMB to track to see the whole network

Select the matchsize node. Wiggle your mouse to break it away 
from the node network. Move it down and place it on the line 
between color and CUP_OUT. Use the same method to move the 
color node from the bottom to just under the tube node.

Select all of the nodes. Press A then drag down from the first node 
in the network to straighten the nodes and distribute them evenly.

02 In the Network view, select the tube and color nodes and 
Alt drag to create copies. Press tab > Switch and place 

the node in between the original color and the polyfill. Wire the 
second color node into the switch. 

Press p to bring up a Parameter pane inside the Network view. Set 
Select input to 1.  

Select the second tube node. Change the Height to 1.2. 

Select the color node and change the second color to red. 

Press p to turn off the Parameter pane.

03 Box select both tube nodes, both color nodes and the 
switch node. Press Shift - O to add a network box with 

these nodes inside it. Double-click in the titlebar and name this 
Starting Shapes.

Now select the nodes from polyfill to subdivide. Press Shift - O to 
add a network box with these nodes inside it. Double-click in the 
titlebar and name this Polygon Tools.

You can move around the boxes to or move the nodes inside the 
boxes. You can also click on the top left corner to collapse the 
network box if you want to reduce clutter.

PART TWO
Work with Nodes
Let’s take a detour from modeling the cup to work with the nodes in the Network view. The nodes act as a recipe that de-
scribes the flow of data from the top to the bottom of the network. Keeping this view of your scene organized and easy to read 
is important for when you return to it later on in production or when you share your work with others and you want them to 
understand how you created the shot. 

NODE FLAGS
When you mouse over a node, this radial menu lets you toggle 
on and off several flags. The Display flag sets this node as the 
node you can see in the Scene view. The Bypass flag turns off a 
node to see how the network functions without it. The Template 
flag lets you see a node in wireframe while working with other 
nodes. The Freeze node blocks changes from the node and 
nodes up the chain from the frozen node from working. 

Toggle Bypass

Info Box

Toggle Freeze

Toggle Display

Toggle Template

Press A 
and  
Drag 
Down

Swap 
nodes

Alt-drag
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05 In the Node view, Press C to bring up the Color Palette. 
Select the switch node and change it to yellow. Change 

the tube and color nodes on the left to orange and the ones on 
the right to red. You can also select and add color to the Network 
boxes.

Again this will help you organize your network and find these nodes 
later on.

06 In the Node view, Press Shift-P to add a sticky note to 
the network. You can use this to annotate a part o your 

network. 

Another way to annotate a specific node is to use the Node flag 
menu to bring up the Info box. Near the bottom is a comment field. 
Fill that in then turn ON the Show Comment in Network button. 
Now you have more information for other artists exploring your 
network.

07 Move down to the bottom of the network. Press Y and 
drag over the line connecting matchsize and CUP_OUT. 

This breaks their connection.

Press J and drag down from matchsize to CUP_OUT. This 
reconnects the nodes. You can use this with multiple nodes if 
needed.

08 Move the CUP_OUT node down and to the right. Press 
Alt and click on the line to add a dot to the line. Add a 

second one then move the dots to create two right angles. 
Network dots are useful organizing tools that you can use to make 
your network more readable.

Most of these steps don’t have any affect on what happens in the 
Scene View. But they are very important to help you manage the 
nodes that created as you work in Houdini. 

Now back to creating 3D stuff!

04 In the Node view, Press Z to bring up the Shape Palette. 
Select the switch node and change it to a circle. Change 

the tube and color nodes to distinguish them. 

Some nodes have shapes when they are first built. You have the 
ability to change the shapes to help the readability of your network.

Y

Alt-click

Alt-click

J
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NAVIGATING NETWORKS
Nodes can be nested in other nodes, network managers or 
subnetworks. These container nodes have a white drop shadow. 
Double-click on node containers to jump in, press u to jump up.  

You can also use the browser-like path at the top of most 
panes to navigate these hierarchies. Click on this path to 
jump up and down the hierarchy or to go to other networks.  
You can also use the Back and Forward Buttons to navigate.

Back/Forward Buttons

             Path Hierarchy

02 Press c and choose Create > Geometry > Box. Press 
Enter to place it at the origin. Double click on the box 

node to dive down into this object, Set the following:
	� Size to 0.75, 5, 0.75

In the Scene view, select the box geometry then press tab > Match 
Size. Set Justify Y to Min to Same and Offset by to 3. This lifts the 
box up above the cup. In the Top view use the handle to center the 
box over the middle of the cup.

03 Navigate back to the Object level. Make sure nothing is 
selected. On the Modify shelf, click on Copy to Points. 

Select the sphere and press Enter then select the box and press 
Enter. Press 4 to go to primitive selection mode so you aren’t 
visualizing points anymore.

There is now one sphere attached to every corner point. The nodes 
from the two objects have been merged into one object. 

On the copytopoints node set Pack and Instance to ON. Select the 
Target Points text and remove it. This text could limit the number of 
copied spheres. An empty field lets you copy to all points.

01 In the Scene view, press c to bring up a radial menu. From 
this menu, choose Create > Geometry > Sphere. Press 

Enter to place it at the origin. This creates a new sphere object

Press i to dive down into the sphere object. You can still see the cup 
as a ghosted shape. You will use the cup as a guide. 

On the sphere node, set the following:
	� Uniform Scale to 0.4

PART THREE
Create a Gumball Simulation
In this shot, you are going to drop gumballs into the cup you just modeled. To do this, you want to place gumballs above the 
cup. Using a box and then scattering points onto the box, you can get a nice collection of gumballs. You also leave yourself the 
chance to change the number of gumballs at any point. You will also use attributes such as color and pscale to add some variety 
to the gumballs. The key is that you leave yourself open to the possibility of changes down the line.

Object Level

Object [Geometry Container]
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06 Return to Frame 1. Go to the Object level. Select the cup 
object in the Scene view and from the Modify shelf, click 

on the Extract tool. This merges the cup into different network.  

Go back to the Object level. In the Network view, shift-select the 
sphere and then the extract_object. From the Modify shelf, click on 
the Combine tool. 

Go back up to the Object level and rename the new combined 
network to gumballs then press i to dive back in.

07 Select and delete the display_merge node.  Move the 
object_merge node to the right side and wire its output 

into the fourth input on the rbdbulletsolver node. When you mouse 
over the inputs you will see a pop-up that says Collision Geometry 
(input)

At the bottom left edge of the Timeline, click on the Global 
Animation Options button. Set the End to 72 and click Close. This 
will set the timeline range to 72 frames. 

Press Play. The gumballs now fall on top of the cup but not into the 
cup. It seems like the cup is a solid shape. Stop playback.

05 Make sure your timeline is at Frame 1. Press tab >RBD 
Bullet Solver. Place this node at the end of the chain and 

wire the copytopoints output into it. Set its Display flag. 

In the Parameter pane, click on the Collision tab and under Ground 
Collision set Ground Type to Ground Plane. On the Visualization 
tab turn OFF the Ground display.

Press Play to simulate the gumballs. They fall to the ground but 
ignore the cup. This is because it isn’t part of this network yet. You 
are seeing it ghosted from the cup network. Stop playback.

04 In the Network view, press tab > Scatter. Place the node 
down on its own. Set Force Total Count to 60. Move this 

node between box and copytopoints. It will snap onto the wire line. 

Press tab > Attribute Randomize. Place the node between scatter 
and copytopoints. You have 60 colored gumballs above the cup.

Press tab > Attribute Randomize. Place the node between 
attributerandomize and copytopoints. Set the Attribute Name to 
pscale and Min Value to 0.4. 

Now the gumballs come in different colors and sizes. These 
attributes are passing their information to the copytopoints node.

WORKING WITH ATTRIBUTES
Attributes can be assigned to Points, Primitives or Vertices. Some  
typical types of attributes include color (Cd) or UVs. You can see  
the attributes at any point in your chain by mousing over a node and 
choosing the i from the radial menu. You can also review the attribute 
values in the Geometry Spreadsheet panel.

In this lesson, you will be adding color and pscale attributes that are 
passed down from the points to the copied spheres.
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11 In the Network view, RMB-click on the first output of 
the rbdbulletsolver node and choose File Cache. Place the 

node down and set its Display flag. Set the Base Name to gumballs 
and turn OFF the Version.

Press Save to Disk. This runs through the simulation which should 
be fast because the sequence was cached on playback. At the end, 
the Load From Disk option is turned on and now you can scrub 
freely without the simulation slowing things down.

If you later want to tweak the simulation then you just need to press 
the Save to Disk button to capture your changes.

09 Return to Frame 1. Click on the object_merge node and 
press the Jump to Operator button to navigate back to 

the cup network. Select the switch node and change the Select 
Input to 0 to go back to the first cup design. 

Press the Jump Back button on the Network view to go back to the 
gumballs network.

Press Play. The gumballs now fall into the bigger cup with only a 
few spilling to the ground. Stop playback.

10 Return to Frame 1. Select the box node and change its 
Size Y to 10. Now select the scatter node and change the 

Force Total Count to 200. 

Press Play. A lot more gumballs fall into the cup with a lot of them 
spilling to the ground. Stop playback and return to Frame 1.

Houdini’s node-based workflow allows you to explore options and 
create multiple iterations as you art direct your shot. This flexible 
workflow supports the creative process and is a part of all aspects 
of Houdini.

08 Return to Frame 1. Select the rbdbulletsolver node. On 
the Collision tab, set Collision Shape to Concave. This 

will allow the inside of the cup to be taken into account. Click on 
the Properties tab and set Bounce to 0.8.

Press Play. The gumballs now fall into the cup with some spilling to 
the ground. Stop playback

You can set Bounce and Friction on the gumballs using the 
Properties tab, the cup on the Collision tab and the ground using 
the Ground Collision section. Explore different settings to see how 
they affect the results.

NODE TYPE | LOPS
You have used object nodes and dived into them to create geometry using Surface Operators 
or SOPS. You are now going to move your work to Solaris which is the Lighting Operator or 
LOP context in Houdini. The Solaris environment can be found in the /stage network. 

Here you will place nodes for bringing in geometry, assigning materials and adding lights and 
cameras. The Solaris environment converts everything into USD [Universal Scene Descrip-
tion] which is an open source format created by PIXAR. The Solaris/LOPS context allows 
you to work with USD which is needed to render to the Karma XPU renderer.
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PART FOUR
Layout, Lookdev & Lighting
To create a scene for rendering, you are going to bring the geometry into the Solaris or LOPS context of Houdini. LOPS are 
used to prepare the scene for rendering. For studios building more complex lighting pipelines Solaris offers a wide range of 
scene management tools. For an artist creating a single shot like the gumball scene, the setup is much simpler and even though 
you are using USD you will barely notice it.

04 Press tab > Quick Surface Material and place the node 
off to the side. Rename this node to cup_mat. 

Alt-drag on that node to create a second Quick Surface Material. 
Rename this node to ground_mat. Change its Base Color to grey.

Press tab > merge. Wire the node after the geo_merge node and set 
its Display flag. Rename it to mat_merge. Wire cup_mat into ground_
mat and then ground_mat into mat_merge.

02 In the Network view, press tab > Grid. Place down the 
node and rename it ground.  Set Import Path Prefix to /

geo/$OS. This will use the name of the node and place it in /geo. 
You can see this in the scene graph. 

Double-click on the ground node to dive down to the geometry 
level. Select the grid node and set the size to 100, 100. 

RMB-click on the output on grid and choose UV Project. Place the 
node down and set its Display flag. Click on the Initialize tab and 
click the Initialize button. Go back to the Transformation tab and 
set V Range to 0, -1. This will orient the UVs properly.  

03 Press u to go back to the Stage level. Right now either 
the grid or the cup are not visible in the Scene view or in 

the Scene Graph. Press tab > merge. Place the node down and set 
its Display flag. Rename it to geo_merge.  Wire the ground and cup 
nodes into geo_merge. Both are now visible.

01 Change the desktop to Solaris. Make sure you are 
looking at the Stage in the path bar. Turn off the grid in 

the top right on the Display Options. Press D to open, click on the 
Background tab and set Color Scheme to Dark.

In the Network view, press tab > Scene Import and click to place 
the node down. Name this node cup_geo. Set the Destination Path 
to /geo. Next to the Objects field, click on the node selector button 
and from the pop up window, select the cup object.  

Click Accept Pattern. In the Scene Graph in the lower left you will 
see geo. Click on the + sign to open it up to see cup.
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08 From the LOP Lights and Camera shelf, click on the 
Point Light tool then press Enter to place it so you are 

looking through it. Change back to camera1. 

With the node active, press Shift-F to turn on the Shadow mode. 
You can also click on it in the Operation Control bar. Now click on 
the top of the cup to set a pivot point then Shift-click to place a 
target on the ground. 

Ctrl-Drag to set the light distance. Ctrl-Shift-drag to change the 
intensity of the light. You may need to set it quite high to see some 
impact on the look of the cup.

06 In the Scene View, use your view tools to get a good look 
at the cup. From the LOP Lights and Camera shelf, click 

on the Camera tool. This adds a camera node to the chain that 
matches the view you set up.  In the top right of the Scene View, 
you can see that you are looking through camera1.  

07 You can use the camera handles in the center of the view 
to adjust the view. Or you can go to the right side of the 

Scene View, click on the  Lock camera to view button. Now 
use the View tools [Spacebar-LMB/MMB/RMB] to tweak the 
position the camera. 

IMPORTANT: When you finish, toggle off the Lock Camera button 
in order to avoid accidentally losing your chosen camera view. If 
this button is off then you will lose the camera but it is easy to get it 
back by rechoosing it from the menu.

05 Nothing changes in the Scene view because these 
materials haven’t been assigned yet. For this you need 

the Material Linker node.

Press tab > Material Linker and place the node at the end of the 
chain then set its Display Flag.

In the Parameter pane, drag the cup_mat from the Material List 
to the Rules section. Open up the geo folder under Geometry 
Tree and drag cup to the shader part of the rule. The cup still looks 
orange because its color is being multiplied with the material color.

Repeat these steps for the ground_mat and the ground geometry. 

MATERIALS IN SOLARIS
The Quick Surface Material LOP gives you access to a shader that has been pre-
built using Material X then stored in the USD format. A Quick Surface Material 
is actually an Edit Material Properties node that loads this USD file. You can then 
rename it and edit its properties for use in your scene. 

You can also build materials using a Material Library node and a Karma Material 
builder but the Quick Surface Material will meet your needs in many situations. 
You can also access a Catalog of materials on the Material Linker node. 

Lock camera to view

Shift-click

Click

12

H
O

U
D

IN
I F

O
U

N
D

AT
IO

N
S 



12 Return the view to looking through the camera.  If you 
want to tweak the two lights then select them and adjust 

their angle, intensity or position. 

Or you can wait until after the materials are in place. At that point 
you will learn how to use a Light Mixer node.

Save your work.

10 Click on the menu just to the left of the camera menu, 
and set it to Karma XPU. Now you are using the Karma 

renderer in the viewport.

11 Tumble around - go back to camera1.

If you have an Nvidia graphics card with the 
latest drivers installed, you can turn on the Optix Denoiser 
to resolve the image more quickly. Turn it on in the Display 
Options bar or press d and set Enable Denoising in the 
Render Display Options.

09 From the LOP Lights and Camera shelf, click on the 
Point Light tool then press Enter to place it so you are 

looking through it. Change back to camera1. 

With the node active, press Shift-F to turn on the Shadow mode. 
You can also click on it in the Operation Control bar. Now click on 
the top of the cup on the other side to set a pivot point then Shift-
click to place a target on the ground. 

Ctrl-Drag to set the light distance. Ctrl-Shift-drag to change the 
intensity of the light. This light is your secondary light so it can be a 
little less intense.

INTERACTIVE LIGHTING TOOLS
The light tools provides a number of interactive tools that let you make 
lighting decisions from the camera’s point of view. 

Instead of zooming out, adjusting the light handles then looking through 
the camera and back and forth, you can use these handles to make  
decisions from the best vantage point. 

Use the hints to help determine some of the shortcuts and use the  
Operation Control bar to change modes.

Shift-click

Click

Enable Denoising
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04 Go back into the ground_map_mats node. Select and 
delete the checkerboard node. Press tab > Tile Pattern 

and place down the node. Wire the tiles output into input1 on the 
base_color node. Change Pattern Type to Windmill.

Now press tab > Constant and place the node under the tilepattern 
node. In the Parameter pane, set signature to RGB and make 
the color Red. Now add a Multiply node and insert it between 
tilepattern and base_color.  Wire the constant node into the fg input. 
Now you have red Tiles with black grout.

02 Double-click on the ground_map_mats node to dive into 
the network. In the Scene view you can now see the 

map on a 3D grid. Another way to see it is to click on the plus sign 
in the tab section and choose New Pane Tab Type > Viewers > 
Composite View. 

In this view, click on the arrow in the top right and choose Split 
Pane Left/Right. In the section on the left, click on Scene View. 
Now you can see both displays.

03 In the Scene View, click on the Pin icon to lock the view 
to its path. Now click on stage to navigate back up to see 

the Karma XPU rendering of the shot. Now double-click on the 
ground_map_mats node to dive back into the cop network.

Select the checkerboard node and change the Odd Color to Red. 
You can see the texture update in both the Scene view and the 
Composite view.

Go up to the Stage level and select the ground_mat node. Scroll 
down in the Parameter pane to the Maps section and open it. Set 
UV Scale to 5, 5. This will repeat the checkerboard several times.

01 Select the ground_mat node. Set Base > Color back to 
white. Click on the circle on the left side of the Color 

Map parameter and choose Set or Create. This displays a UV grid 
on the ground surface. 

On the far right of the parameter, click on the Create COP texture 
for this map button. Now there is a green and white checkerboard 
texture on the ground.

PART FIVE
Texture the Ground
To add texture to the ground, you will use the COP or Copernicus context to work with procedural images. You can start this 
using a button on the Quick Surface Material and then build up your network from there. You can set up nodes that feed into 
color, specular and normal maps but use the same image nodes to feed all three. This gives you the flexibility inside Houdini to 
explore the right look for your surface without going out to a separate image processing application.
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07 Go back into the ground_map_mats node. Select and 
the tilepattern node and change Pattern Type to French 

Pattern.  The viewport rendering may not update correctly. 

Click on the Karma XPU Persp pulldown in the Scene View and 
choose Restart Rendering. Sometimes a kickstart is needed to 
handle some updates.

08 Go up to the Stage level. Click on the arrow pointing to 
the right on the divider between the Scene view and the 

Composite view.  This will hide the Composite view but you will be 
able to bring it back if needed.

Save your work. 

06 Select and delete the two new checkerboard nodes. Wire 
the tiles output on the tilepattern node to the specular_

color input and the blur node’s source input. 

Right now the grout feels a little too thick. To fix this select the 
tilepattern node and change Divisions to 4 then go up to the Stage 
level and on the ground_mat node, set UV Scale to 15, 15. This 
creates more tile and less grout.

05 Go up to the Stage level and select the ground_mat node.  
In the Specular section, click on the circle on the left side 

of the Color Map parameter and choose Set or Create then click on 
the Create COP texture for this map button. 

Scroll down to the Bump section and set Bump Style to Normal. 
Click on the circle on the left side of the Bump Normal Map 
parameter and choose Set or Create then click on the Create COP 
texture for this map button. 

Go back into the ground_map_mats node to see the new nodes that 
have checkerboard nodes feeding into them.

NODE TYPE | COPS
For working with 2D images for either the creation of texture maps or slap comps, 
the Copernicus context is where you will find COP nodes. These nodes can be 
viewed in a 3D or a 2D view and you can hook them onto materials to render with 
Karma XPU. The Quick Surface Material makes it very easy to set these up. 

Note: This context is in beta with Houdini 20.5. Its purpose in this lesson is for you to 
see its potential. Please test it out and provide feedback to SideFX.
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03 Alt-drag on the cup_mat node to create another Quick 
Surface Material and wire it between the cup_mat and 

ground_mat nodes. Rename this node to gumball_mat.

Select the materiallinker node and in the Parameter pane, drag the 
gumball_mat from the Material List to the Rules section. Open up 
the geo folder under Geometry Tree and drag gumball_sim to the 
shader part of the rule.

04 Select the gumball_mat node. You can now set some of 
its parameters to distinguish this material.
	� Under Base, set Metalness to 0.8 
	� Under Specular, set Roughness to 0.3. 

This provides a different and shinier look for the gumballs.  

02 Click the Jump Back button twice on the Network 
view. This takes you back to the stage level. Press tab > 

Reference and place down the node. 

Wire it into the geo_merge then in the Parameter pane, go to the 
File Pattern parameter and click on the File chooser button. Select 
$HIP > usd > gumball_sim.usd to get the cached simulation file.

Set the Primitive Path to /geo/`@sourcename` in order to set this up 
for the Scene Graph.

Go to frame 33 to see the gumballs falling.

01 In one of the path widgets at the top of any pane, click 
on stage and from the menu choose obj. Double-click 

on the gumball object to dive into it. At the end of the chain, add 
a USD Export node, set its Display flag. Rename this node to 
gumball_geo. Set its Relative Path Prefix to /geo/$OS. 

Click on the Export tab then set Valid Frame Range to Render 
Frame Range and set Output File to $HIP/usd/gumball_sim.usd. 
Click the Save to Disk button.

PART SIX
Render the Gumballs
The renderings so far have focused on the cup and the ground surface. It is time to add the gumballs to complete the shot. This 
time, you will export the geometry directly to a USD file then reference that back onto the stage. For animated pieces like the 
gumballs, this works better when rendering with motion blur since the motion is already cached. After the gumballs are in place 
you will need to set up and assign another material.
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LIGHT MIXER NODE
The Light Mixer node shows off some of the layering capabilities of  
Solaris. Instead of going back and adjusting the original light nodes, the 
Light Mixer node lets you layer changes on top of the original nodes.

In addition to the sliders, you can also go to the Transforms tab, select a 
light then use the viewport tools to adjust it. This gives you a great deal  
of flexibility to make final adjustments before rendering.

07 In the Network View, press tab > Karma to add a Karma 
Render Settings and USD Render ROP node. 

Wire them into the end of the chain. Select the karmarendersettings 
node and set Engine Settings to XPU parameters. 

On the Image Output > Filters tab set Denoiser to nvidia Optix 
Denoiser to turn the denoiser back on.

Set the Output Picture to $HIP/render/gumballs_$F2.exr. The $F2 
adds frame numbers to the renderings with a padding of two.

Save your work.

08 On the  usdrender_rop node, set Valid Frame Range to 
Render Frame Range and turn on Render All Frames 

With a Single Process. 

On the usdrender_rop node, make sure to set the Render Delegate 
to Karma XPU then click Render to Disk. 

When the renderings are finished, choose Render > Mplay > Load 
Disk Files and open up the rendered images to review the shot.

If you want to create a movie, use the Mplay File menu and choose 
Export > FFmpeg. Set the Output File to $HIP/gumball_sim.mp4 
and press Save.  

06 Click on the Star icon to Solo each light to determine its 
contribution then tweak Exposure to adjust the lighting. 

Since the intensities are so high you can click on the icon above the 
intensity bar and from the pop-up set a Max value that works for 
your shot.  

When you are finished be sure to turn off the Solo button to see all 
the lights.

05 In the Network view, RMB-click on the last pointlight 
node’s output and type Light Mixer then press Enter to 

place the node and set its Display Flag. This will create a panel in 
the Parameter pane which has a list of lights on the left side. 

Drag the two lights from the list to the area on the right. 

You can play with the intensity and exposure for the two lights here 
without making changes to the original lights. This way if you don’t 
like your edits it is easy to go back to what you had or branch off 
and try a different setup with a different Light Mixer node.
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PART SEVEN
Last Minute Changes
The client calls after reviewing the shot and wants to change the gumballs to little candy eggs. The first step is to reshape the 
original sphere, then you will need to resimulate and recache the results. The client also proposes some compositing effects 
which you can add using a Slamp Comp created with Copernicus nodes. The compositing network can be applied onto your 
rendering right in the Scene view to make creative decisions for your final rendered sequence.

04 Go back to the stage. Add a Reference node and place it 
in between the last pointlight and the karmarendersettings 

nodes. 

Set File Pattern to $HIP/usd/eggs.usd. At first you see both the 
gumballs and the eggs. Change the Primitive Path to /geo/gumballs. 

Now the egg simulation replaces the gumballs and the material 
is assigned properly. You are using the path to layer the new 
simulation on top of the old one. This is one of the abilities of the 
USD framework.

02 The client also wants the simulation to be a bit longer. At 
the bottom left edge of the Timeline, click on the Global 

Animation Options button. Set the End to 120 and click Close. 

To see how this affects the simulation, you can Display the 
rbdulletsolver node and run the sim. You may want to adjust some 
parameters to get the look you want for this new shape. 

When you are happy select the filecache node and change Base 
Name to eggs. Press the Save to Disk button to save out this new 
simulation The Start and End will now be 1, 120. 

03 Now go to the USD Export node and change the Output 
File to $HIP/usd/egg_sim.usd.The Start and End should 

also be 1, 120. Click Save to Disk to save this new USD file.

If you replace the gumball USD file with this new one the names 
will be wrong and the materials will not get assigned properly. Lets 
layer the new simulation later on in the network. 

01 Go back to the object level and double-click on the 
gumball node. Set the Display flag on the sphere node 

then go to the Front view and press Spacebar-g to focus on the 
sphere. Zoom out just a little. 

Get the Select tool and press 2 to get point selection then click on 
the point at the top of the sphere. Press t to get a translate handle 
and move the point up. Set the Soft Radius to smooth out the edit 
to create an egg shape. An edit node is added to your network to 
accept this change.
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08 You can also render to disk using the Slap Comp. Go up 
one level to the stage. Select the karmarendersettings 

node and set the Output Picture to $HIP/render/eggs_
slapcomp_$F2.exr. 

Go to the Image Output tab and the AOVs (Render Vars) sub tab 
scroll down to the Utility section and open it. Check off the Depth 
(Camera Space) option to turn it ON. This is needed for the Slap 
Comp to work when rendering to disk.

06 Press tab > HSV Adjust. Place the node between the 
two block nodes. Now click on the Control Slap Comp 

Settings button on the Display Options bar.

On the hsv node, drag on the Hue Shift slider. You see the Scene 
view being affected by the adjustment.

You could also bring up a Composite view pane and make these 
adjustments with that view in mind.

07 Go to another frame where you see the eggs. Drag the 
Saturation Scale to 0 make the image greyscale.

Press tab > Glow. Place the node between the hsv node and 
the block_end. Drag on the Brightness slider to add glow to the 
highlights. 

You can turn on and off the Control Slap Comp Settings button to 
see your image with and without the Slap Comp adjustments.

05 Go to Frame 1. In the Network view, press tab > COP 
Network then place the node. Make sure your Scene 

view is still pinned then double-click to dive into it.

Press tab > Slap Comp Block. This adds three nodes to your 
network. This first imports in your Scene View image, while the 
second two define the slap comp.

SLAP COMP
Slamp Comp using the Copernicus context to composite your rendering right 
in the Scene view then apply that to your final rendered sequence. 

This workflow gives lighters the ability to explore ways make compositing a 
part of the rendering process. They can then send notes to the compositors 
down the production line to apply what is learned here.

Individual artists can use this to add effects such as glow at render time.

Control  
Slap Comp  

Settings
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CONGRATULATIONS
You have now completed your first steps into the world of Houdini and its node-based workflow. You have used 
these nodes to model, simulate, texture and render a simple shot. 

Along the way, you experienced the ability to make changes in support of your creative decisions. As you made 
those changes, they passed information down the node chain to update the results. Every part of Houdini uses 
nodes and as you complete more tutorials, you will see how easy it is to make changes and art direct your work.

You have also learned that different Houdini nodes work in their own context. You used object [OBJ] nodes to 
start your scene then built the cup using Surface Operator [SOP] nodes. You set up the lighting and lookdev of 
your shot using Solaris [LOPS] nodes and added textures using Copernicus [COP] nodes.

You have learned how nodes from each type can connect to and support other networks. You have also learned 
that different types of nodes can differ in how they are wired together and each have unique capabilities.

Learning these different node types is key to understanding 
Houdini. As you continue your work, you will learn how to 
use the “secret” language of SOP, LOP, COP etc. to talk 
about and explore Houdini.

09 On the usdrender_rop node, go to the Husk tab and then 
the Slap Comp tab. Click on the plus sign to get a Slap 

Comp. Set the Source to COP Network then use the file selector to 
find the block_end of the slap comp network.

Save your work.

10 On the usdrender_rop node, click Render to Disk. 

When the renderings are finished, choose Render > 
Mplay > Load Disk Files and open up the rendered images to 
review the final sequence.

If you want to create a movie, use the Mplay File menu and choose 
Export > FFmpeg. Set the Output File to $HIP/eggs_sim.mp4 and 
press Save. 


