
HOUDINI FOUNDATIONS

TERRAIN 
GENERATION
Houdini includes a dedicated toolset for generating and shaping terrains. These tools represent terrain  
using 2D volumes, called heightfields, where each voxel contains the height of the terrain at a particular 
grid point. The Houdini viewport lets you visualize 2D heightfields as 3D surfaces. You can also set up mask 
fields that can be used to focus your edits to specific parts of the terrain. In this lesson, you will build up 
terrains using patterns, noise and erosion then export the results for use in a game engine.

LESSON GOAL
Create a landscape using the Heightfield tools in Houdini and bring it into Unreal Engine or Unity. 

WHAT YOU WILL LEARN
	� How to create a Terrain using heightfields
	� Add patterns, noise and distortions
	� Create Masks using terrain features 
	� How to create Scatter Points on heightfield 
	� How to set up Instancing using Terrain Scattering
	� Export the Terrain as a Digital Asset [HDA]
	� Import the HDA into Unreal Engine

LESSON 
COMPATIBILITY
Written for the features in Houdini 19.5+

The steps in this lesson can be 
completed using the following 
Houdini Products:

Houdini Core ✔

Houdini FX ✔

Houdini Indie ✔

Houdini Apprentice ✔

Houdini Education ✔
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PART ONE
Shape the Terrain using Heightfields
To create terrains in Houdini, you will work with heightfields. You will start with a blank height-
field then add some noise and distortion to define the basic look of the landscape. As you work, 
you can tweak parameter values on the nodes while layering in details. 

01 Go to the Desktop selector and choose Terrain. This 
will give you shelf tools and radial menus focused on 

terrain. Turn off the Reference Plane using the button at the top 
of the Display options then press d in the viewport and from the 
Background tab set Color Scheme to Dark. 

Select File > New Project.  Set the Project Name to terrain_lesson 
and press Accept. Select File > Save As... You should be looking into 
the new terrain_lesson directory. If not then click on $JOB in the 
sidebar and you will be looking at the directory. Set the file name to  
terrain_01.hip and click Accept to save. 

02 From the Terrain Tools shelf, click on the HeightField 
tool. Press Enter to place it at the origin. Press Spacebar 

H to show the whole heightfield. 

This defines a 1000 x 1000 grid with a grid spacing of 2.

03 Use the main radial menu (hotkey c) to select Deform > 
Noise. Set the following:
	� Noise Type to Worley Cellular F1
	� Amplitude to 360
	� Offset to 20, 0, 300

This kind of noise gives you a good starting point for your terrain.

Use the main radial menu to choose Deform > Blur to access the 
Heightfield Blur tool. Set the Radius to 20. This softens the edges 
to make them feel worn by time.
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following:
	�  Amplitude to 40
	� Element Size  to 220

This node moves the existing values around by advecting them 
through a noise field. You can use the parameter values proposed 
here or explore on your own to get a look that you like better. 

Houdini’s procedural approach would even allow you to come back 
later and change the parameter values to see how different settings 
affect the outcome.



06 Use the radial menu to choose Mask > Mask by Feature. 
Set the following:
	� Min Slope Angle to 35
	� Max Slope Angle to around 60

This lets you focus on areas on the side of the mountain. 

If you were to go back and change the shape of the terrain feeding 
into this node then the mask would update accordingly. 

05 Use the radial menu to choose Deform > Noise. Set the 
following: 
	� Amplitude to 10
	� Element Size to 20.

Select the last four nodes in the Network view then click on the 
Network box icon to add a Network box. Adjust its edges to shape 
the box then click in the top bar and name it Shape the Terrain.

Network boxes make it easier to read the network especially if you 
share your file with other artists.

07 From the radial menu, choose the Erode > Slump. Set 
Spread Iterations to 75. 

The heightfield_slump node creates a type of erosion that moves 
unstable piles of rubble into a more stable configuration. It affects 
the Mask layer and also outputs to the Flow and Flow Direction 
layers.

If you MMB-click on the node, you can see which layers are being 
created. You can MMB-click on an earlier node in the chain for 
comparison.

08 From the Terrain Tools shelf, choose the Heightfield 
Remap tool. Set Layer to Remap to Flow then click on 

the Compute Range button. Set Output Max to 1 to normalize 
these values. Use the radial menu to choose Mask > Clear Mask. 
This clears the mask layer so that you can use it to create more 
layers in your setup. 

Select the last four nodes in the Network view then click on the 
Network box icon to add a Network box. Adjust its edges to 
shape the box then click in the top bar and name it Create Flow 
Mask. Save your work.

HEIGHT LAYERS
The data passing through a geometry network can contain multiple height fields. 
In the terminology of Houdini’s terrain tools, these are called height layers. For 
example, a tool might use one height layer to represent bedrock and another to 
represent loose soil on top. The default height layer is named height.
Each voxel contains a “selected-ness” value, called a mask layer. Most terrain 
nodes take a second input that can contain a mask layer to control which parts 
of the terrain the node will modify. The default mask layer is named mask and is 
displayed as a red tint on the 3D surface.
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PART TWO
Add and Visualize Mask Layers
You can set up layers on your terrain by first populating the mask then copying that information 
to a particular layer. You can do this more than once to add more layers. These layers can be 
used later to visualize key aspects of the terrain. 

01 From the radial menu, choose Mask > Mask by Feature. 
Under Mask by Slope, set the following: 
	� Min Slope Angle to 0
	� Max Slope Angle to around 45. 

Turn on Mask By Direction then set:
	� Goal Angle to around 136
	� Angle Spread to 180. 

These settings cover a larger area of the terrain including the 
valleys.

02 From the radial menu, choose Layer > Copy Layer. Leave 
the Source set to Mask and set the Destination to slope. 

By copying the mask to a new layer, it leaves you free to clear the 
mask and use it for other tasks.

From the radial menu, choose Mask > Clear Mask. This again clears 
the mask layer so that you can use it to create more layers in your 
setup. Add a network box to organize your nodes and call the box 
Create Slope Mask.

03 Use the main radial menu to select Mask > Mask by 
Feature. Under Mask by Slope, set the following:
	� Min Slope Angle to 0
	� Max Slope Angle to around 70.

Turn on Mask By Curvature and set:
	� Max Curvature to 0.5. 

Next move the Curvature Ramp points in towards the center to 
find the peaks of the terrain. This gives you a very detailed mask 
that you can use to find the peaks of all the key features in the 
landscape.

04 From the radial menu, choose Layer > Copy Layer. Leave 
the Source set to Mask and set the Destination to peaks. 

Afterwords, choose Mask > Clear Mask. This again clears the mask 
layer. 

You now have three layers that have all been derived from masks. 
Add a network box to organize your nodes and call the box Create 
Peak Mask.

You will use these in the next step to visualize the terrain.
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06 Under the ramp widget, set the following:
	� Layer 1 to peaks
	� Layer 2 to slope
	� Layer 3 to flow

The default colors are now visible in the 3D view using the three 
layers you built up using masks. You will now use these to define 
the look of the terrain. 

05 From the radial menu, choose Visualize > Heightfield 
Visualize. Click on the Compute Range button to align 

the visualization with the current heightfield range.  

This sets the ramp visualizer to go from the base of the terrain to its 
peaks. You can see how the ramp looks in the 3D view where the 
mountain tops are highlighted in white. 

07 Set all three of these layers to white. [1, 1, 1] This gives 
a snowy look to the landscape. You can use these layers 

for any number of different features, but for this mountain, snow is 
the look that you want to emphasize.

08 In the Height Ramp, select and remove all the markers 
except two. Set the one on the right to black and the 

one on the left to dark grey. This creates a darker look under the 
snowy layers which helps the dark areas pop out visually. 

Save your work.

VISUALIZING HEIGHTFIELDS
To visualize your heightfields, you start with a ramp that is assigned to 
the overall height of the terrain. You start by Computing the Range that 
the ramp will apply to then you can adjust the colors in the ramp itself 
to visualize your landscape.

You can then add colors to the various layers that will sit on top of the 
ramp. This lets you create a richer look for your scene.
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PART THREE
Remap and Erode the Terrain
Right now some of the heightmap is below 0 and some is above. You are going to use a Remap 
node to change the range and then use the ramp on that node to add a ridge around the moun-
tain. You will then erode the landscape to add new layers to the terrain.  

01 Find the Heightfield Noise node at the end of the Shape 
by Terrain Network box. Turn on its Display Flag and click 

to select his node.  

From the Terrain Tools shelf, click on the Heightfield Remap tool. 
Click on the Compute Range button. To reframe the heights, set the 
following:

	� Output Min to 0
	� Output Max to 300

02 Using the Remap ramp, add points in the middle then 
add and adjust the following points:
	� Point 2 has a Position of 0.25 and a Value of 0.25 
	� Point 3 has a Position of 0.4 and a Value of 0.27.

This creates a ridge running along the base of the mountain.  

03 Choose Erode > Erode. Click on the Visualization tab and 
click the Compute Range button. Press Play to watch the 

terrain erode. Stop around frame 15.

 

04 Set the Display flag back to Heightfield Visualization 
node at the end of the chain. Set Layer 3 to water which 

is a layer that is coming from the erode node and change its color 
to a blue. This will bring out some of these areas in the visualization.  
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PART FOUR
Scatter points on the Terrain
To add trees and rocks, you will mask out the new plateau area then set up a special terrain 
scatter that will use this mask. These scattered points will then be used to copy instanced cones 
designed to represent trees. These will be replaced later in Unreal.  

01 Use the radial menu to choose Mask > Mask by Feature. 
Set the following:
	� Min Slope Angle to 0
	� Max Slope Angle to 50

Turn on Mask by Height and set the following:
	� Min Height to 70
	� Max Height to 85 

This should highlight the plateau created with the remap node. If 
not then tweak these values until you isolate this area in the Mask.

02 In the Network editor RMB-click on the output of the 
maskbyfeature node and start typing scatter… 

Place the Heightfield Scatter down and set turn on its Display flag. 
Now wire the output of the maskbyfeature node into the second 
input of the scatter node to restrict the points to the area defined 
by the incoming mask.

Set Coverage to 0.05. Turn off the Keep Incoming Terrain option. 

03 In the Network Editor, press tab and begin to type Copy 
to Points and click to add this node. Click the Pack and 

Instance check box to turn it on. Wire Heightfield Scatter into the 
second input of Copy then set its display node. 

In the Network Editor, add a tube node down then feed it into the 
first input of the copytopoints node. Set the following: 

	� Radius to 0, 2 and Radius Scale to 1
	� Height to 10 and Center to 0, 5, 0. 

Add a color node after the tube to make the trees green. Add a 
Merge node and feed Heightfield Visualize and copytopoints into it.  

04 Go back to the heightfield_scatter  node and turn off the 
Match Normals with Terrain and Match Direction with 

Slope.  This will ensure that all the trees are pointing up. 

Now change Random Up to 10 to create some variation in their 
direction and set Randomize Yaw to 20. You cannot see the effect 
of this but if you replace the tree later you will see random rotation.

The Scale of the trees is controlled by Variability. Change the Range 
to 1, 2 to create random scales these two values.
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01 Select all the nodes in the Network editor. Click on the 
Create Subnet from Selected Button. RMB-click on the 

new subnet and choose Digital Asset> Create New. 

Set the Type Name to terrain and turn off Branch and Version. Set 
Library Path to HIP File Directory and Library Filename to Node 
Name. 

Click Create. The Edit Type Properties window opens up. Click 
Accept to close this window.

02 Open Unreal Engine and from the main panel click on the 
New Project tab and choose the Third Person template. 

Click Create Project. When it opens, delete the default geometry 
so that it doesn’t get in the way of your terrain.

From the Content Browser, click Import to Game and find the 
terrain.hda asset file. Drag the asset from the Content Browser to 
the 3D workspace. Set the ThirdPersonCharacter up to a Translate 
Z of around 10,000 then press Play and walk around the terrain.  

03 Go to the Houdini Instanced Inputs section and expand 
terrain1_1. This is the cone instance which you can 

replace with content from within Unreal.

In the Content Browser, open StarterContent > Props. Drag the 
SM_Bush prop over to the Houdini Instanced Input. Set the Scale 
Offset to 5, 5, 5. The geometry is instanced to the points then 
randomly scaled and rotated just like the cones. 

In the outliner, select the Landscape node under terrain. Beside 
Landscape material, click on the menu and find a grass material.  
Press Play to explore the Terrain.

PART FIVE
Open the Terrain in Unreal
To bring the landscape into game engines such as Unreal Engine or Unity, start by creating a Houdini Digital Asset. Once 
you have the Houdini Engine plug-in set up properly, then this asset can be loaded into the game editor with the copied 
tree stand-ins importing as instanced objects. When you import the terrain into Unreal Engine, the heightfields will be 
recognized as a landscape. You can also import the asset into Unity using the Houdini Engine plug-in.

CONCLUSION
You can also use the terrain layers to create texture maps that you can work 
with to define the look of your landscape. You can do this using the Heightfield 
Output node. You can then use these channels to build a material in the Unreal 
Engine that references the features of the landscape.

This quick look at the terrain features in Houdini will open up a wealth of possi-
bilities for artists creating landscapes for their games then populating them with 
details such as rocks and trees.
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